dyld: Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib

SOLUZIONI

Stavo lavorando su attività di training AI e nel tentare di scaricare dei data set con wget

wget --no-check-certificate <URL>

mi sono imbattuto nel seguente errore  :

dyld: Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib

il sistema di riferimento su cui si è presentato l’errore è un “macOS Catalina  ver. 10.15.3“.  Per risolvere il problema dopo aver provato a re-installare inutilmente le librerie openssl,  ho verificato le versioni di openssl a disposizione andando ad esplorare il contenuto della directory /usr/local/Cellar/openssl, eseguendo il comando:

ls -al /usr/local/Cellar/openssl

a questo punto ho provato tra le versioni disponibili le alternative, lanciando il comando:

brew switch openssl <version>

la versione che ha risolto il problema nel mio caso è la : “1.0.2s“, che ovviamente ho selezionato attraverso il comando:

brew switch openssl 1.0.2s

Buone cose.

Comments